6.5. パッケージの依存関係

インストールやアンインストールの時には、依存関係というものが発生します。以下のように判断された時ににはエラーになってしまいます。

  1. インストールしようとするパッケージが、他のパッケージや機能に依存していながら、それが用意されていない
  2. アンインストールしようとするパッケージが、他のパッケージに必要とされているため、アンインストールするとシステムに不具合をもたらす可能性がある

例えば、httpdというパッケージは、複数のパッケージに必要とされているため、アンインストールしようとすると以下のような依存性のエラーが出ます。

この問題を解決するには、必要なパッケージを同時にインストールしたり、必要ないのであれば、依存関係にあるパッケージをまとめてアンインストールしたりする必要があります。

# rpm -e httpd

エラー: 依存性の欠如:

httpd-mmn = 20051115 は (インストール済み)php-5.3.3-3.el6_2.5.x86_64 に必要とされています

httpd-mmn = 20051115 は (インストール済み)php-zts-5.3.3-3.el6_2.5.x86_64 に必要とされています

httpd >= 2.2.0 は (インストール済み)gnome-user-share-2.28.2-3.el6.x86_64 に必要とされています

〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜〜

しかしながら、依存関係を破壊してでも処理したいという場合もあるかもしれません(依存しているパッケージを後から入れる場合など)。このような時には“–nodeps”オプションを用いることで、依存関係を無視して強制的に処理を行うことができます。ただし依存性を無視した場合には、システムに何らかの影響が出る可能性がありますので、“–nodeps”オプションの使用には注意が必要です。

–nodeps                         パッケージの依存関係を検証しません。
–nosuggest                      不足する依存関係の解決を提案しません。

その他実際のインストールは行わず、テストを行う“–test”オプション等もあります。

# rpm -e httpd –test

エラー: 依存性の欠如:

httpd >= 2.2.0 は (インストール済み)gnome-user-share-2.28.2-3.el6.x86_64 に必要とされています

他にも様々なオプションがあります。下記のオプションで確認して、パッケージの検証に役立てて下さい。

# rpm -?